Commit ca371f1d authored by Ted Young's avatar Ted Young Committed by Corey Innis

Upgrade gibberish gem.

Resolves Digest::Digest deprecation warning.

[#75227366]
Signed-off-by: default avatarCorey Innis <cinnis@pivotal.io>
parent 592c14af
......@@ -27,7 +27,7 @@ PATH
remote: bosh-core
specs:
bosh-core (1.2941.0)
gibberish (~> 1.2.0)
gibberish (~> 1.4.0)
yajl-ruby (~> 1.2.0)
PATH
......@@ -367,7 +367,7 @@ GEM
fog-core
nokogiri (~> 1.5, >= 1.5.11)
formatador (0.2.5)
gibberish (1.2.2)
gibberish (1.4.0)
highline (1.6.21)
httpclient (2.4.0)
inflecto (0.0.2)
......
......@@ -18,7 +18,7 @@ Gem::Specification.new do |spec|
spec.test_files = spec.files.grep(%r{^(test|spec|features)/})
spec.require_paths = %w[lib]
spec.add_dependency 'gibberish', '~>1.2.0'
spec.add_dependency 'gibberish', '~>1.4.0'
spec.add_dependency 'yajl-ruby', '~>1.2.0'
spec.add_development_dependency 'rspec', '~> 3.0'
......
......@@ -125,7 +125,7 @@ module Bosh::Core
handler = EncryptionHandler.new('client_id', @credentials)
expect {
handler.decrypt('f')
}.to raise_error(EncryptionHandler::DecryptionError, /TypeError/)
}.to raise_error(EncryptionHandler::DecryptionError, /ArgumentError/)
expect {
handler.decrypt('fddddddddddddddddddddddddddddddddddddddddddddddddd')
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment